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Wizard for EEG Information Tabling – “WEEGIT” is a software designed for visualization and an-
notation of the long-lasting records of activity. Long-lasting records of raw data are used in various
areas of life sciences and well represented in neuroscience. In spite of development of other tech-
niques and approaches the electrophysiological activity registration remains the “golden standard”
in neurobiological research. Therefore, we developed and verified “WEEGIT” as a powerful and
convenient tool for electrophysiological recordings’ description. We combined the most important
features presented in other commercial and noncommercial software in the “WEEGIT”. Presented
software can operate with widely used formats of records. ”WEEGIT” allows adaptive visualizing
of up to 512 channels of record in different timescale without loss of efficiency and consumption of
large machine resources. Visualizing also includes optional built-in temporal-spatial analysis (den-
sity of current sources or the density of action potentials) displayed as a background image. Integra-
tion of a set of optional filtering and signal transforming procedures allows improving record visu-
alization. “WEEGIT” has a convenient graphical user interface with opportunity of simultaneous
time browsing and annotating of the records in one workspace. Annotation can be done by simple
text information typing as well as an interactive placing of specialized labels and objects. Software
also allows saving data in the resampled format, both for the whole record and for user-defined
events. In conclusion, “WEEGIT” provides a great set of benefits for the convenient workflow for
beginners and specialists in the electrophysiological area of research, including preparation of the
data for further specialized analysis.
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1. INTRODUCTION
Despite of wide usage of the optogenetic ap-

proaches, electrophysiological recordings (inva-
sive and non-invasive extra-/intracellular record-
ings in vitro and in vivo) are still the main tool for
the neurophysiological research both in science
and medicine. Recently, developing technologies
have led to significant increase in resolution of
electrophysiological data both in space and in
time domain. Altogether, with simultaneous re-
cordings of the telemetric information, that pro-
vided a huge set of data for research and diagnosis.
A large variety of modern analytical packages
showed exciting opportunities for deep analysis of
the electrophysiological recordings (Hazan,
2006; Tadel, 2011; Patel, 2017; Siegle, 2017; Nasi-
otis, 2019). However, during experiment or diag-

nostics, the first overview of the data doesn’t re-
quire all analytical power of the mentioned soft-
ware. Moreover, verification of the observing
patterns of activity very often can be done only vi-
sually for the first time. Thus, for the first pre-
analysis stage, the operator should be able to an-
notate recorded electrophysiological information
to prepare it for further specialized analysis. This
important part of the scientific and diagnostic
workflow is a first stage of education of the begin-
ners like postgraduate student or intern. There-
fore, complexity of the software architecture and
graphical user interface can be a critical point for
rapid engagement of them. At the same time, ef-
fective interaction between experimenters and an-
alysts was always a cornerstone of scientific work-
flow. That means, as more documented and rep-
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resentative information was provided by
experimenter, as more qualitative will be analysis,
and opposite. Therefore, for the first pre-analysis
stage software should provide opportunities for
easy visualization, annotating, collecting and sav-
ing of important episodes of activity in both man-
ual and automatic way. A clear preparation pro-
cess will simplify interaction in discussion be-
tween experimenters and analysts, and provide
high efficiency of workflow. Besides that, low skill
in programming or neurophysiology area will be
leveled by multiple choice of activity detection.
Thus, efficient engine for fast visualization and
annotation of the electrophysiological recordings
are the main keys of the pre-analysis stage. How-
ever, representation of large volumes of data also
highly sensitive to the hardware, requiring essen-
tial machine resources. Obvious solution for
downsampling in time and space domain will re-
duce the quality of the observed patterns and can
critically bias conclusions about activity. There-
fore, for the effective usage of machine resources,
software should avoid uploading the full set of da-
ta, while recognition of patterns shouldn’t be af-
fected.

Following the concept described above, we de-
signed a powerful and convenient desk tool for vi-
sualization and annotating of the electrophysio-
logical activity registration data. Here, we present
WEEGIT software, that combines a fast and effi-
cient visual component with extended text editor
opportunity. A simple and intuitive graphical user
interface allows the operator to add and edit infor-
mation about general features of the record as
well, as a specific event properties. Software en-
gine provides control of the spatio-temporal reso-
lution of the record with resource-efficient visual-
ization. Altogether, that allows the user to do fast
and efficient browsing and annotating of the elec-
trophysiological recordings.

2. WEEGIT GRAPHICAL USER 
INTERFACE

WEEGIT graphical user interface contains
panels for displaying and marking data, drop-
down menu tabs and toolbar panel. Some avail-
able menu actions are duplicated with buttons or
editing opportunity on the panels. The name of
the record and status of the applied filter and
transform have no unique panel and are placed in
the top left part of the graphical user interface.

2.1. Panels

Panels functions can be classified in three
groups: 1) graphical representation of the data;
2) editable information about current recording
and 3) log of the user actions (Fig. 1).

EEG channels. The main panel “EEG chan-
nels” displays amplifier channels extracted from
the electrophysiological record. “EEG channels”
panel is consisted of 1) attributes control space
(upper position); 2) main axes with record data
(middle position) and 3) navigation control space
with time and sweep control elements (bottom
position). During session saving, all parameters of
the elements on the “EEG channels” panel are
saved in an additional filename. WEEGITwee-
git.mat file. During connecting to the file-
name.lfp, an additional file filename. WEE-
GITweegit.mat will be automatically uploaded (if
it exists) and state of the elements on the “EEG
channels” panel from the last session will be re-
stored (see “File” → “Save session settings” in
“Menu” section and “Session” in “Methodolo-
gy” section).

Attributes control space. “Attributes control
space” is intended for user regulation of graphical
elements’ presence in the “Main axes”. The left
part of “attributes control space” includes ticks to
visualize/hide on the main panel the following at-
tributes: “traces”, “spikes”, “events”, “event edg-
es” and “periods”. Right part of attributes control
space presented by reserved space for the back-
ground color-code horizontal bar (on the left)
and background selection popup menu (on the
right). Background selection popup menu offers
three modes: 1) “CSD” (current source density);
2) “spike density” and 3) “nothing”. “Spike den-
sity” mode selection starts evaluation of the aver-
age spike’s number in the adaptive sliding window
(Fig. 1). “CSD” mode selection starts evaluation
of the current source density distribution, base on
the second spatial derivative (Buzsaki, 2012) be-
tween each signal presented in main axes (fig. 2).
That, in a certain manner, provided information
about spike rate at the moment. The size of sliding
time window is adaptively changing according to
the signal window time range. That provide re-
markable representation of the spike density in a
different time scales, however, spike rate in this
case may be biased according to the scale. “Noth-
ing” mode remove background from the “Main
axes” (Fig. 3).

Main axes. “Main axes” contains graphical rep-
resentation of the objects “traces”, “spikes”,
“events”, “event edges”, “periods” and background
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image. “Traces” are record data, organized vertical-
ly, where each row contain signal from one single
electrode. Represented as vertical solid black lines

(if background is “nothing” or “CSD”) or as ver-
tical solid white lines (if background is “spike
density”). “Spikes” are action potentials, high-

Fig. 1. WEEGIT interface view 1, using spike density as background. The main panel (EEG channels) displays am-
plifier channels extracted from the electrophysiological record. The additional panel (Analog inputs (AI)) displays
data from other sensors (e.g., telemetry sensors) synchronized with electrophysiological data. General information
panel (File info) is intended for downloading (in *.txt format) and/or creating and editing text information about the
current record. The panel of morphological labels (Layers) is used for marking the correspondence of channels to
morphological structures. The segment saving panel (Segment to save) contains editable time values defining inter-
vals before and after each event (in milliseconds) that will be used to save data segments around the event timestamp.
The period information panel (Periods) is used to enter/edit time period information if the user needs to mark the
time period during which the experiment conditions were changed/intact. The action overview panel (Log) displays
non-editable information about ongoing user actions.
Рис. 1. Вид 1 интерфейса WEEGIT, в качестве фона используется плотность потенциалов действия. На ос-
новной панели (EEG channels) отображаются данные регистрации электрофизиологической записи для
каждого канала усилителя. На дополнительной панели (Analog inputs (AI)) отображаются данные с других
датчиков (например, с телеметрических сенсоров), синхронизированные с электрофизиологическими
данными. Панель общей информации (File info) предназначена для загрузки (в формате *.txt) и/или созда-
ния и редактирования текстовой информации о текущей записи. Панель морфологических меток (Layers)
предназначена для обозначения соответствия каналов морфологическим структурам. Панель сохранения
сегментов (Segment to save) содержит редактируемые значения времени, определяющие интервалы до и
после события (в миллисекундах), которые будут использоваться для сохранения сегментов данных вокруг
временной метки каждого события. Панель информации о периодах (Periods) используется, если необхо-
димо, для ввода/редактирования информации о периоде времени, в течение которого изменялись/сохра-
нялись условия эксперимента. Панель обзора действий (Log) отображает нередактируемую информацию
о действиях пользователя.
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frequency events with duration from 1 to 2 ms, ex-
tracted from each signal in user-defined way. This
type of graphical objects is specific for recordings
with high-impedance electrodes and optional for
other types of electrophysiological recordings.
Timestamps for spikes represented as red (default)
squares horizontally aligned to the source channel
position. In future release, color will represent af-
filiation to cluster. “Events” are customized
events’ times, defined and prepared by user. Rep-
resented as vertical dash-dotted black line (if
background is “nothing” or “CSD”) or as vertical
dash-dotted white lines (if background is “spike

density”) with triangle on the end. Each event has
a unique name, displayed by text with the same
color as the line. If event set as “bad” the color of
line and text becomes red for any background.
”Event edges” are boundaries for the segment
around each event, which times are defined in the
“Segment to save” panel. Represented as vertical
dotted black line (if background is “nothing” or
“CSD”) or as vertical dotted white lines (if back-
ground is “spike density”). “Periods” – boundar-
ies for the user defined time periods of interest.
Represented as vertical solid magenta line. Peri-
od’s left boundary name displayed as magenta du-

Fig. 2. WEEGIT interface view 2, using current source density (CSD) as a background. The upper drop-down menu
contains sets of actions for: converting/loading/saving data (File); changing display settings (Channels); filtering da-
ta (Filter); transforming data (Transform); detecting action potentials (Spikes); detecting/labeling/saving events
(Events); setting/editing time periods (Periods); initial analysis of events (Analysis); studying the basic functionality
of the program (Help).
Рис. 2. Вид 2 интерфейса WEEGIT, в качестве фона используется плотность источников тока (ПИТ). Верх-
нее выпадающее меню содержит наборы действий для: конвертации/загрузки/сохранения данных (File);
изменения настроек отображения (Channels); фильтрации данных (Filter); преобразования данных (Trans-
form); обнаружения потенциалов действия (Spikes); обнаружения/маркировки/сохранения событий
(Events); установки/редактирования временных периодов (Periods); первичного анализа событий (Analy-
sis); изучения основных функциональных возможностей программы (Help).
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al-line text and consist of user-defined name
(top) and “start” string (bottom). Period’s right
boundary name displayed as magenta dual-line
text and consist of user-defined name (top) and
“stop” string (bottom). The y-axis of the “Main
axes” contains numbers of the record channels.

The background image is defined by the user
through the background selection popup menu.
Only the current configuration of channels will be
used for the background build, if channels are
hidden or sorted by user management (see
“Channels” → “Configure EEG” in “Menu”
section). The resulted background image is dis-
played as a background image in jet color code.
The background color-code horizontal bar shows
the color correspondence between values and col-
ors. The “Scale” push button placed in the bot-
tom left corner of the main axes. Pushing this but-
ton calls the user dialog with three fields: “Scale
factor”, “Scale units” and “Background scale”.

The value of the “Scale factor” is applied to all
channels in the current configuration and regu-
lates the y-scale stretching. The value of the
“Scale units” is an optional field, which is not
based on record features and should be filled by
user as text string, containing information about
measurement units. “Scale factor” and “Scale
units” values are finally combined to the text
string and displayed with a vertical scale bar in the
upper right corner of the main axes. The color of
text and scale bar are black (if background is
“nothing” or “CSD”) or green (if background is
“spike density”).

The value of the “Background scale” is a two-
element vector with minimum and maximum
limits for the color map of the background image.
Image values, which exceed user defined limits,
will be marked with gray color. “Background
scale” value displayed as left and right text mark-
ers for the background color-code horizontal bar

Fig. 3. WEEGIT interface view 3, no background. Example of ∼30 min of record.
Рис. 3. Вид 3 интерфейса WEEGIT, без фона. Пример отображения ∼30 мин записи.
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in the “Attributes control space” of the “EEG
channels” panel.

Navigation control space “Navigation control
space” is intended for the timescale management.
That space contains: 1) a horizontal slide bar with
two additional push buttons “ ” and “ ” on the
left and right border, respectively; 2) “start point”
edit window; 3) “duration” edit window; 4) “time
step” edit window; 5) “sweep #” edit window
with two additional push buttons “∧” and “∨” on
the left border; 6) “resampling” non-editable
window.

”Start point” edit window defines the starting
timestamp in milliseconds, while ”Duration” edit
window defines the duration in milliseconds for
the time window of data, displayed in the “Main
axes”. “Time step” edit window defines the time
to the next start point and increment for slide bar.
Slide bar values are based on the “Start point”,
“Duration” and “Time step” values. Changing of
the slide bar position lead to the change of “Start
point” value. Slide bar can be moved manually by
drag/using slide bar buttons, or automatically us-
ing push buttons “ ” and “ ”. Push buttons “ ”
and “ ” allow the user to change start point con-
tinuously backward or forward, respectively. First
press on push button “ ” or “ ” initiates contin-
uous browsing, while second press stops it. Con-
tinuous browsing also stops if slide bar reaches the
maximum position, while the “Start point” value
in this case evaluated as difference between dura-
tion of all record (in milliseconds) and “Dura-
tion” value. If the slide bar reaches the minimum
position, the “Start point” is set to 0. The time ax-
is of the “Main axes” contains 11 time ticks with
real time of record window begin, end and 9 inter-
mediate values in between, providing 10 equal in-
tervals for any scale. The time units have default
value of “ms” (milliseconds), but adaptively
changing and have values of “s” (seconds), “min”
(minutes), “hour” (hours) if “Duration” value
exceed 2 s, 10 min, 1 h, respectively. ”Duration”
value is finally combined with the time unit text
and displayed with a horizontal scale bar in the
upper right corner of the main axes. The color of
text and scale bar are black (if background is
“nothing” or “CSD”) or green (if background is
“spike density”).

“Sweep #” edit window is intended to record
type, using sweep (or trial) mechanism of record
build (*.abf format, for example). In this case, us-
er can define the interested sweep by direct edit of
“Sweep #” window or by using increment or dec-
rement of 1 sweep with buttons “∧” and “∨”, re-
spectively. If the record contains only one sweep

! @

! @ !
@

! @

(or trial) “Sweep #” edit window is noneditable,
and buttons “∧” and “∨” are not active.

Analog inputs (AI). The additional panel “An-
alog inputs (AI)” displays data from other sensors
(e.g., telemetry sensors) synchronized with elec-
trophysiological data. “Analog inputs (AI)” panel
contain axes for sensors’ record data (AI chan-
nels) with white background, legend for AI chan-
nels and regulation pushbuttons “Scale”, “Shift”
and “Y limit”. Each AI channel property of scale
and y-position can be separately regulated with,
respectively, pushbuttons “Scale” and “Shift” in
the bottom right corner of the “Analog inputs
(AI)” panel. “Scale” pushbutton calls a user dia-
log with two fields: “Scale factor” and “Chan-
nel”, where the user can define unique scale fac-
tor (“Scale factor” vector of values) for corre-
sponding channels (“Channel” vector of values).
Vectors of values in both fields should be equal in
length. “Shift” pushbutton calls a user dialog with
one field “AI channel shift”, where the user can
set the vector of constant values, which will be
added to each AI channel y-position. Length of
vectors of values should match with number of AI
channels. The pushbutton “Y limit” in the bot-
tom left corner of the “Analog inputs (AI)” panel
allows the user to set an upper and lower limit for
the y-axis. ”Y limit” pushbutton calls a user dia-
log with one field “AI Y-limits”, where the user
defines two elements. Altogether, pushbuttons al-
low the user to distribute AI channels in the best
way of representation, while AI channels have dif-
ferent y-ranges. The legend contains information
about correspondence between color of the pre-
sented lines and number of the AI channel. The
time axis of the “Analog inputs (AI)” panel are
equal to the time axis of the “Main axes” in “EEG
channels” panel and following the same rules as
described in “Main axes” subsection. “Events”
and “events edges” are also displayed in the “An-
alog inputs (AI)” panel, following rules described
in “Main axes” subsection. However, despite the
background image, the line color of “events” and
“events edges” is always black. Only the current
configuration of AI channels will be used for the
background build, if channels are hidden or sorted
by user management (see “Channels” → “Config-
ure AI” in “Menu” section). During session sav-
ing, all parameters of the elements on the “Analog
inputs (AI)” panel are saved in an additional
<filename>.weegit.mat file. During connecting
to the <filename>.lfp, an additional <file-
name>.weegit.mat file will be automatically up-
loaded (if it exists) and state of the elements on
the “Analog inputs (AI)” panel from the last ses-
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sion will be restored (see “File” → “Save session
settings” in “Menu” section and “Session” in
“Methodology” section).

File info. General information panel “File in-
fo” is intended for downloading (in *.txt format)
and/or creating and editing text information
about the current record. Text can also be pasted
from any text source with copy-paste mechanism.
Downloading of the *.txt file is available in “File”
menu (see “File” → “Load info file” in “Menu”
section). During session saving, text from the
“File info” panel is saved in an additional file-
name.weegit.mat file. During connecting to the
filename.lfp, an additional filename.wee-
git.mat file will be automatically uploaded (if it
exists) and text in the “File info” panel from the
last session will be restored (see “File” → ”Save
session settings” in “Menu” section and “Ses-
sion” in “Methodology” section). Graphical rep-
resentation of the text is based on “finjobj.m”
function (Altman, 2023).

Layers. The panel “Layers” is used for mark-
ing the correspondence of channels to morpho-
logical structures in the editable table. The first
table column “layer” contains editable cells with
unique string names of user defined morphologi-
cal structures. The second table column “chan-
nel” contains editable cells with channel num-
bers, corresponding to morphological structures
in the first column. An additional blank row add-
ed in the bottom of the table after setting paired
values of layer/channel. All blank rows except the
last one are automatically removed from the table.
During session saving, the table from the “Lay-
ers” panel is saved in additional filename.wee-
git.mat file. During connecting to the file-
name.lfp, an additional filename.weegit.mat
file will be automatically uploaded (if it exists)
and the table in the “Layers” panel from the last
session will be restored (see “File” → “Save ses-
sion settings” in “Menu” section and “Session”
in “Methodology” section).

Segment to save. The “Segment to save” panel
contains editable time values defining intervals
before and after the event (in milliseconds) that
will be used to save data segments around the
event timestamp. “Before” edit window defines
the time from event timestamps toward negative
infinity in milliseconds, while “after” edit win-
dow defines the time from event timestamps to-
ward positive infinity. Those values are used to
display event edges in the “EEG panel” (see
“EEG channels” → “Main axes” in “Panel” sec-
tion), to extract data for the interactive plugin (see
“Session” → “Analysis” in “Methodology” sec-

tion) and to save events in “autosave segments”
mode (see “Events pipeline” in “Methodology”
section). During session saving, the values from
the “before” and “after” edit window are saved in
additional filename.weegit.mat file. During
connecting to the filename.lfp, an additional
filename.weegit.mat file will be automatically
uploaded (if it exists) and the values for the “be-
fore” and “after” edit window in “Segment to
save” panel from the last session will be restored
(see “File” → “Save session settings” in “Menu”
section and “Session” in “Methodology” sec-
tion).

Periods. The “Periods” panel is used to en-
ter/edit time period information if the user needs
to mark the time period during which the experi-
ment conditions were changed/intact. The first
table column “name” contains editable cells with
unique string names of user defined period time
range. Period name is set to the “newperiod” value
by default, if the user was using “Periods” tab to de-
fine period interactively (see “Periods” → “Set
new…” in “Menu” section and “Periods pipeline”
in “Methodology” section). The column “start-
time” contains editable cells with start time of the
period, while “stoptime” contains editable cells
with end time of the period. The columns “start-
time” and “stopsw” contains editable cells with
start and end sweep number, respectively. The
values of the “starttime” and “stopsw” are auto-
matically set to 1, if the record has one sweep. An
additional blank row added in the bottom of the
table after setting paired values of layer/channel.
All blank rows except the last one are automatical-
ly removed from the table. During session saving,
the table from the “Periods” panel is saved in ad-
ditional filename.weegit.mat file. During con-
necting to the filename.lfp, an additional file-
name.weegit.mat file will be automatically up-
loaded (if it exists) and the table in the ”Periods”
panel from the last session will be restored (see
“File” → “Save session settings” in “Menu” sec-
tion and “Session” in “Methodology” section).

Log. The “Log” panel displays non-editable
information about ongoing user actions. Informa-
tion about data load/save is marked as black text
and began with green triangle symbol. Informa-
tion about parameters changing is marked as blue
text and began with green circle symbol. Informa-
tion about mode activation/deactivation is
marked as orange text and began with lamp sym-
bol. Information about error is marked as red text
and began with attention symbol. “Clear” push-
button is used for removing log text. During ses-
sion saving, the log text is not saving. However,
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that will be implemented in the future release.
Graphical representation of the text is based on
“finjobj.m” function (Altman, 2023).

2.2. Menu
Menu tabs are the expanded popup menus

with the main “WEEGIT” functions. Some fre-
quently used actions are duplicated with pushbut-
tons on the panels and/or have a hotkeys.

File
Connect *.lfp – loading data from *.lfp file;
Autoconnect *.spk – custom flag for autoload

*.spk data, corresponding to current *.lfp file;
Load info file – loading text data from *.txt file;
Convert to *.lfp – converting data from (*.abf,

*.daq, *.csc, *.xdat, *.rhd, *.edf, *.continious) to
simple binary *.lfp file;

Export to *.mat – exporting data to *.mat file
with user-defined acquisition rate;

Save session settings – save settings for the cur-
rent session to *.weegit.mat.

Channels
Configure EEG button – set order and compo-

sition of channels which should be displayed on
EEG panel;

Configure AI button – set order and composi-
tion of channels which should be displayed on AI
panel;

Set AI y-shift button – set y-shift for each chan-
nel on AI panel;

Set AI y-limits button – set y-limit for all chan-
nels on AI panel;

Use AI names button – custom flag for using
original channel names instead of numbers

Filter
Notch – notch filter for EEG channels;
Highpass – Chebyshev Type II highpass filter

for EEG channels;
Lowpass – Chebyshev Type II lowpass filter for

EEG channels;
Bandpass – Chebyshev Type II bandpass filter

for EEG channels;
Bandstop – Chebyshev Type II bandstop filter

for EEG channels;
Unfilter – remove filtering for EEG channels.
Transform
Extract average – remove spatial average value

from all channels in each time point
Remove – remove transform for EEG channels

Spikes
Load from *.spk – loading spikes data from

*.spk file;
Search… – a dropdown menu with following

items:
– Above STD – search spikes with amplitude

below-2 standard deviation of the filtered (0.4-
4kHz) signal;

– Above threshold – search spikes above
threshold (in next release);

– Custom script – search spikes using custom
script (in next release).

Events
Load from *.spk – loading spikes data from

*.event-X.mat file;
Search… – a dropdown menu with following

items:
– Above threshold – search events from the us-

er-defined channel above userdefined threshold;
– Above threshold – search events as a TTL ris-

ing edge from the user-defined channel;
– Spikes accumulation – search events as on-

sets of spikes density function increase.
Add (manual)… – add events manually using

pointer tool;
Set/unset bad event – mask/unmask bad

event/events by manual placement in the interval
using pointer tool;

Set name – define name for the events;
Remove by name – remove events from the ses-

sion using unique name;
Remove manual – remove events from the ses-

sion by manual placement in the interval using
pointer tool;

Remove all – remove all events from the ses-
sion;

Autosave with segments – custom flag for au-
tosave segments around events;

Save – save all events from the session.
Periods
Set new… – a dropdown menu with following

items:
– Start point – set start point for the default pe-

riod name “newperiod” using pointer tool;
– Stop point – set stop point for the default pe-

riod name “newperiod” using pointer tool;
– Start/stop points – set start and stop point for

the default period name “newperiod” using
pointer tool;

Remove – remove all periods from the session.
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Analysis
General:
– Depth overview – combined LFP-spikes

depth profile for user-defined event;
LFP – (in next release);
Spikes – (in next release);
Console – console mode for applying custom

self-made scripts (beta).
Help
Hot keys – information about interface;
About – information about software.

2.3. Toolbar
Zoom “+” – zoom in for EEG channels / An-

alog inputs;
Zoom “–” – zoom out for EEG channels /

Analog inputs;
Drag tool “hand” – tool for moving all traces

manually;
Pointer tool “cross” – tool for displaying point

coordinates;
Duplication tool “printer” – tool for copy EEG

and Analog inputs panels to additional figure;
Help tool “?”– help dialog (or F1 button).

3. METHODOLOGY
“WEEGIT” is following a simple workflow.

On “Preprocessing” stage, data are converted to a
simple raw binary filename.lfp format, while re-
lated information about the record is saved in the
filename.json file. Firs step of the “Session”
stage is always a connection to the filename.lfp
file with automatic upload of the additional file-
name.weegit.mat file (if exists). Afterward, the
user is able to browse through data (see “Brows-
ing”), annotate the record (see “Annotating phys-
iological information”), extract action potentials
(see “Action potentials extracting”), set events
(see “Events pipeline”), set periods (see “Periods
pipeline”) and make simple time-spatial analysis
(“Analysis”). All changes during “Session” stage
are saved by the user in the filename. wee-
git.mat file and restored during next connection
to the file.

3.1. Preprocessing
Preprocessing stage is an important step for

data preparation. The user cannot use the “WEE-
GIT” ignoring this stage, where data are convert-
ed to readable for presented software format.

“WEEGIT” can convert the following formats of
electrophysiological activity registration – *.abf,
*.daq, *.csc, *.xdat, *.rhd, *.edf, *.continious.
The result of convert is presented by file-
name.lfp file, while information extracted from
the header of the original file is saved in the file-
name.json file. The name of the file corresponds
to the original name of the file with just replacing
the extension to *.lfp (for example, from file-
name.abf to filename.lfp). For the formats
which use a separate file for each channel (*.csc or
*.continious) the name of the converted file is
based on the pathway to folder, containing origi-
nal separate files (for example, from file-
name/filename.csc to filename.lfp). The
filename.lfp file is organized as a raw vector of
16-bit integer type, which corresponds to the
structure of three-dimensional array with follow-
ing dimensions: [number of channels, acquired
samples, number of sweeps]. The filename.json
file is organized as a structure with following
fields: name of the file, original type of the file,
date of the file creation, time of the file creation,
number of channels in file, number of record
points per each channel in the file, number of
sweeps in file, sampling interval (in microsec-
onds) of the record and channels parameters
structure. Afterward, created files are placed in the
same location, as original files. It should be noticed,
that filename.lfp and filename.json should be al-
ways in one folder, otherwise “WEEGIT” will be
not able to load file correctly.

3.2. Session

“Session” stage is available, when file-
name.lfp and filename.json are generated (see
“Preprocessing”). User connect program to the
filename.lfp file for the workflow. During “Ses-
sion” file cannot be removed or replaced from the
original folder. “WEEGIT” is using technology
of consecutive reading of the data during each re-
cord portion request, therefore removing source
of data will lead to program fail. Connection is ac-
complished by using “File” → “Connect *.lfp”
menu, which calls user dialog for choosing file
through file browser. If additional file filename.spk
was prepared before (see “Action potentials extract-
ing”), it will be not uploaded automatically, while
user will not put “File” → “Autoconnect *.spk”
flag to active state. File filename.spk contains
data for spikes representation. Therefore, without
connected filename.spk file graphical informa-
tion about spikes or analysis requiring that will be
not functional. “Session” stage is characterized
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by ongoing changing of great amount of the pa-
rameters of time navigation and annotation infor-
mation. Therefore, the user have an opportunity
to save the current state of the “Session” to start
from the same state during future connections. It
can be done by saving all session parameters in
filename.weegit.mat file. Saving is available in
“File” → “Save session settings” menu, which
immediately generate, or replace filename. wee-
git.mat file in the same folder as a source file-
name.lfp file. Renamed filename.weegit.mat
files can also be used as a template for other ses-
sions. However, for now it should be done manu-
ally and will be automatized in the future release.

Browsing. During “Session” stage, the user can
browse electrophysiological activity registration data
using navigation tools in “EEG channels” panel (see
“Panels” → “EEG channels” → “Navigation con-
trol space”). Each change in the navigation control
items is followed by refreshing of the graphical data
in the “EEG channels” and Analog inputs (AI)
panels. During refresh, data are grabbed from the
filename.lfp and from filename.spk (if it was
connected) files. Time navigation values are pre-
sented in milliseconds, therefore, time request is
converted to data points accordingly to the origi-
nal sampling rate of the file.

Low-level functions are used to read the binary
file. Number of time points for each graphical ob-
ject in “WEEGIT” is limited to 10000, therefore,
when the number of loaded points of data exceed
10000, data are loaded adaptively. That organized
as resampling data down to 10000 points by ig-
noring some data points during read. Thus, the
portion of loaded data represents the requested
time interval, however sampling rate is reduced.
That allows to load data with millisecond and
hour interval with the same speed and without us-
age additional volume of the operative memory.

Annotating physiological information In “Ses-
sion” stage, the user is able to add comments
about the current record in several ways. Firstly,
the user can type a plain text with information in-
to the “File info” panel. Text can be also upload-
ed through “File” → ”Load info file” menu,
which calls user dialog for choosing *.txt file
through file browser. It should be noticed, that in
this case, all text in the “File info” panel will be
replaced by text from the document (*.txt file).
Secondly, the user can use panels of “Layers” and
“Periods” to add information about morphologi-
cal structure and specific time intervals, respec-
tively. That can be implemented both manually
and interactively (see “Panels” → “Layers” and
“Panels” → “Periods” in “WEEGIT graphical

user interface” section). All information can be
saved in filename.weegit.mat file with all ses-
sion settings in “File” → “Save session settings”.

Filtering and transforming “WEEGIT” allows
the user to filter signals placed in the “EEG pan-
el” in a custom manner. There are a several avail-
able filter types: notch filter, highpass filter, low-
pass filter, bandpass filter and bandstop filter.
Only one type of filter can be applied in the cur-
rent version of “WEEGIT”. Highpass, lowpass,
bandpass and bandstop filters are based on the
Chebyshev Type II filter. After choosing the filter,
the user dialog will ask for the stop frequency or
range of frequencies in the band filter case. Notch
filter will require values of central frequency and
bandwidth factor. To remove any filtering, the us-
er should use “Filter” → “Unfilter” menu. Usage
of the filters has one strong limitation, based on
current resampling frequency of the data (dis-
played in the bottom right corner of the “EEG
channels” panel). Unfortunately, this limitation
cannot be removed, because of the specific ap-
proach used in the “WEEGIT” engine. However,
that will be fixed in the future release.

In “WEEGIT” the user can also transform sig-
nals by application mathematical operations on
each channel. In the presented release, that im-
plemented only in one tool called “Extract aver-
age”, however, in the future release the opportu-
nity of custom operations will be added. “Extract
average” tool allows the user to subtract from each
of the channels in the “EEG channels” the aver-
age value between channels across each time
point. That can remove some artifacts, which a
presented on each channel of the record, howev-
er, in some cases can seriously modify the original
record. “Transform” → “Remove” menu can be
used to remove transforming of the signals. Sta-
tuses of the applied filter and transform are dis-
played in the top left part of the graphical user in-
terface.

Action potentials extracting In “WEEGIT” the
user has an opportunity of extracting and visualizing
of action potentials. In the presented version only
one automatic method is available (“Spikes” →
→“Search…” → Above STD). However, in future
release new opportunities will be added. “Above
STD” is based on the method of detection of fil-
tered signal peaks, that excess predefined thresh-
old. An action potential (spike) is produced by ac-
tivation of the single neuron and represented as a
high-frequency event on the background of local
summarized neuronal activity. Therefore, data
should be filtered to high frequency range. In
“WEEGIT” we use frequency range from 400 to
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4000 Hz to the 2-cascade bandpass Chebyshev
Type II filter. Filtered data are used for detection
of the peaks, which amplitudes exceed 2 standard
deviations of the filtered signal. Timestamps, am-
plitudes, channel, sweep and cluster of the detect-
ed peaks are forming an array, which is saving in
binary file filename.spk. Cluster parameter is 0
by default and was added for future opportunity of
representing spikes from different cluster groups.
Spikes timestamps and amplitudes are saved in
single format, while channel, sweep and cluster
have 16-bit integer format. An additional header
of 100 bytes is added for saving detection method
information. File filename.spk is connected im-
mediately after detection and saving of the spikes.

Events pipeline. One of the important tool of
the “WEEGIT” is detection and labeling of the
events. The event can be defined as any action of
the experimenter (switching on the light, stopping
perfusion etc.) or as a beginning of the physiolog-
ical pattern of activity (oscillation, epilepsy etc.).
In general, an event is characterized as a momen-
tary action.

Detection is a first step of workflow with
events. In “WEEGIT” events can be detected
both manually and automatically. For manual de-
tection, an interactive tool in “Events” → “Add
(manual)” → Above STD is available, while for
automatic detection three possible algorithms are
presented in “Events” → “Search…”. The first
method called “Above threshold” allows the user
to detect events with amplitudes, that excess a
predefined threshold. It calls a user dialog with
three fields: “Channel”, “Threshold” and “Min-
imal interval (ms)”. “Channel” field defines the
channel for detection, and “Threshold” field de-
fines the amplitude of the threshold value. “Min-
imal interval (ms)” the user can set the minimal
interval between events, in which only the event
with the largest amplitude will be detected. The
second method called “TTL pulse” allows the us-
er to detect the rising edge of the TTL (Transistor-
transistor logic)-like signals. It calls a user dialog
with two fields: “Channel” and “Threshold (level
from max value)”. “Channel” field defines the
channel for detection, and “Threshold” field de-
fines the threshold as a percentage from maxi-
mum of the pulse signal. The third method called
“Spikes accumulation” is based on the detection
of rising of spikes density and will be available
soon.

The second step of event’s workflow is label-
ing. After detection, all events are named with
numbers in ascending order starting from “1” and
have “numeric” label. For each sweep, if the re-

cord contains multiple of them, names of detect-
ed events start from “1”. User can change label of
the events through “Events” → “Set name”
menu. It calls a user dialog with three fields:
“Event name”, “Event num” and “Event sweep”.
“Event name” is intended for the text string of
event label, while in “Event num” and “Event
sweep” the user should define the sequential
number (or numbers) of event and sweep of inter-
est, respectively. After the name of the event will
be changed, the text label above will be replaced
from number to the defined name of the event.
Starting from this point, events don’t remember
their numbers and to rename them again re-de-
tection is required. In other case, all detected
events with “numeric” label will be removed, if
the user will apply a new detection without cus-
tom labeling of previously detected events.

The final step of event’s workflow is saving of
the events. After labeling of the events, the user
can save them in files. For each label of the event,
a separate file with name filename.event-la-
bel.mat will be created. There are two possible
ways of event saving: with or without record data.
In the first case, only a table with information
about event timestamps will be saved. Table will
contain the following information about an event:
time of the event (f loat), name of the event
(string), bad or good event (boolean), event edges
exceed or not record time (boolean), sweep of
event detection (float), method of event detection
(string), source of event (string), name of the pe-
riod where event is observed (string). In the sec-
ond case, additionally will be saved a portion of
data around the event, defined by the “Segment
to save” panel parameters. That will include re-
cord data itself for each channel and spikes time-
stamps. Saved events can be uploaded through
“Events” → “Load” menu, which calls user dia-
log for choosing event file through file browser.

Management of the events is presented as an
opportunity of marking of them as “bad” and total
removing from the events set. “Bad” event is follow-
ing to be a part of events set, however, colored as red
line with red label name (see “Panels” → “EEG
channels” → “Main axes” in “WEEGIT graphi-
cal user interface” section). That can be done, if
there is uncertainly evidence, that event should be
removed. Removing of the events can be done in
several ways: manually “Events” → “Remove
manual”, by name “Events” → “Remove by
name” and full remove “Events” → “Remove
all”. The manual method calls an interactive tool
for definition of two time points, between which
all events will be deleted. Removing by name im-
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plies setting of the event’s set label name, which
should be removed. Full remove of the events lead
to total remove of all events.

Periods pipeline. Period’s tool is a convenient
way to mark time ranges in which the experiment
conditions were changed or intact. All events be-
longing to the marked periods will also contain
that information in the resulted event table.
Moreover, that information will be used in the
built-in time-spatial analysis and will be available
for future more progressive analysis. Periods can
be set only manually, however, two approaches
are available. The first one is a usage of interactive
pointing tools placed in the “Periods” → “Set
new…” menu. The user have a choice of defini-
tion only a start point of period, stop point of pe-
riod, or both start and stop points in one time.
The first two cases may be useful in the situation
when start and stop times are far away from each
other, or the user don’t want to define one of the
borders from the beginning. If only one border of
the period time range will be set, the correspond-
ing times in “Periods” panel will be filled with
NaN values. If the user applies an interactive tool
for setting period time range, the name of the pe-
riod will be “newperiod” by default. In this case,
any other applications of the interactive tools will
change times of the period with this name. After-
ward, the user can set the name of the period at
his discretion. The user also able to change any
period parameters directly in the “Periods” panel
at any time he wants. The second approach is
based on direct setting of the period parameters in
the “Periods” panel. During that method, the us-
er should fill all the fields in the table to make a
graphical representation of the period available. Re-
moving of all periods is placed in “Periods” → “Re-
move” menu. However, in the future release, the
opportunity of removing using the period name
will be added.

Analysis “WEEGIT” software is planned to in-
clude a several built-in analyses of time-spatial
properties of the activity. In the presented release,
we include an interactive plugin for monitoring
average properties of the events (Fig. 4) and a be-
ta-version of the console (Fig. 5). In future release
a several simple analyses of local field potential
(LFP) and spikes will be included. “WEEGIT” is
not positioning here as a powerful analysis tool,
however, it is planned, that using the console tool
user will be able to apply any fancy self-made
analysis.

An interactive plugin for monitoring average
properties is used for estimating activity proper-
ties around the detected events. It includes a sep-

arate interactive figure, where the user is able to
parse through the channels using “up” and
“down” keyboard keys. On the figure the follow-
ing panels are presented (from the left to right):
average CSD profile of the event, Peri-event time
histogram (PETH) depth profile, average spike
rate depth profile, target channel average LFP
(top), target channel peri-event time histogram
(middle) and Analog input channels average trace
(bottom).

The console tool allows the user to run and
save custom code in Matlab language. Console is
represented in beta-version, however, will be im-
proved in the future release.

4. FUTURE DIRECTIONS
“WEEGIT” demonstrates a well organized

environment and concept of data workflow.
However, despite obvious benefits, presented
software has some restrictions and deficiencies.
Therefore, future release of the “WEEGIT” will
cover the following key improvements: 1) Resolv-
ing filtering collapse due to the adaptive resam-
pling rate; 2) Graphical representation of spike
clusters for each channel; 3) Basic descriptive
analysis for full record electrophysiological prop-
erties; 4) Events detection using spikes density
raise; 5) User-friendly interface for custom analy-
sis implementation; 6) Event viewer interactive
plugin for browsing events and 7) Include reading
of the *.HDF5 files as the popular format of large,
complex and heterogeneous data store.

5. DISCUSSION
“WEEGIT” is able to work with wide range of

the file formats of electrophysiological activity
registration – *.abf, *.daq, *.csc, *.xdat, *.rhd,
*.edf, *.continious. Presented formats are charac-
terized by absolutely different internal configura-
tion of headers and data organization, however,
almost all of them store data as a raw binary data.
To avoid additional workload during usage of the
“WEEGIT” we decided to convert data formats
to one simply organized raw binary file with head-
er externally stored in a separate *.json file. Data
from a raw binary file can be directly read with a
low-level function, requiring the shortest possible
time for this operation. External file for header
was used, firstly, to avoid difficulties with binary
file header reorganization and, secondly, for easi-
er reading of the header with text editors. This ap-
proach also allows us to standardized data for fu-
ture analysis. However, additional operation for
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data convert required some time and space on the
hard drive, that can be a disadvantage for the us-
ers. Mechanisms of fast visualization are based on
two components: 1) direct reading of the binary
file and 2) adaptive sample rate of uploaded data.
Usage of low-level function to read the binary file
provides the fastest speed, while fixed number of
time points for graphical environment reduce the
required volume of random-access memory.
However, that approach lead to some difficulties
with filtering of the data, because of f loating res-
ampling rate. That restricts filtering in some time
ranges, resulting in deficiency of this operation.

Though, we expect that WEEGIT should pre-
dominantly fit the browsing of electrophysiologi-
cal recordings done with multisite linear elec-
trode, we believe that WEEGIT will be also fruit-

ful for pre-analysis of the electrophysiological
recordings done with other types of electrodes
and electrodes configurations (tetrodes, multis-
hank, single eletrode etc) and in other systems
(ECG, EMG etc). That will be associated with
some functional limitations (loss of MUA or CSD
analysis), however, we prepare the option to add
extra scripts in “Console mode” for future releas-
es. But, the main functions for signal filtering and
transform or detection of the events can be equal-
ly used for any types of electrophysiological re-
cordings.

The opportunity of the simultaneous fast
browsing and annotation of the data in one space
was highly appreciated by the ordinary users of
the similar type of software. However, an over-
view of the popular browsers showed, that, de-

Fig. 4. WEEGIT interface view 4, interactive plugin for monitoring average properties of the events. Two interactive
plugins for one-record events of one type (“tactile stim”), but under various temperature conditions, are presented
(34°C on the left and 41°C on the right).
Рис. 4. Вид 4 интерфейса WEEGIT, интерактивный плагин для мониторинга средних значений свойств со-
бытий. Представлены два интерактивных плагина для событий одного типа (“тактильная стим.”), но при
разных температурных условиях (слева – 34°C, справа – 41°C).
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spite obvious advantages of included analysis
packages, the workflow doesn’t support a conve-
nient way of record documenting at all. For exam-
ple, in the famous software “Clampfit” (Molecu-
lar Devices) annotation capabilities are presented
both with text and interactive methods. However,
the record data from the file are fully placed in the
Random-access memory, meaning large machine
resources consumption in case of large (>10 GB)
files. “Neuroscope” browser (Hazan, 2006) in
opposite, provides a good engine with adaptive
data upload, but on the background of poor orga-
nized annotation abilities. Modern powerful
packages like Real-Time experiment Interface
(Patel, 2017) or NeuroScore (CNS Software)
demonstrate a complex user interface, resulted in
time-consuming process of simple data browsing

and annotation. Assuming that in this case more
time required for the learning of all software fea-
tures, those products more related to the special-
ists neither than to beginners. “WEEGIT” soft-
ware concept is trying to keep the delicate edge
between complexity of the proposed tools and us-
er-friendly interface. Moreover, in modern re-
search, authors prefer to use their custom-build
analysis. Therefore, “WEEGIT” is designed to
provide the simplest descriptive tools for the be-
ginners with ability of immediate application of
fancy analysis by console tool for professionals.

6. CONCLUSION

The “WEEGIT” software can potentially
solve the problem of fast visualization and anno-

Fig. 5. WEEGIT interface view 5, console mode is launched. An example of first time derivative for the 11th channel
is presented (was built using console commands).
Рис. 5. Вид 4 интерфейса WEEGIT, консольный режим включен. Представлен пример первой производ-
ной для 11-го канала (создан с помощью консольных команд).
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tating of the electrophysiological activity data in
the field of basic scientific research and can be ap-
plied in medicine diagnostics, for example, in de-
scription of brain EEG. The program works with
the majority of widely used formats of electro-
physiological activity data recording. The pro-
gram does not consume significant hardware re-
sources due to adaptive displaying algorithms.
The opportunity of visualizing and documenting
the observed electrophysiological activity is de-
signed within one interface. Doesn’t require spe-
cific knowledge of programming, physiology or
medicine, so it can be used with equal success by
beginners and specialists in any of these fields. At
the same time, the information is systematized
and prepared for further analysis by more special-
ized algorithms. Thus, the program additionally
allows optimal organization of interaction be-
tween biomedical specialized personnel and ana-
lytical department with physical and mathemati-
cal specialization.

7. HARDWARE AND SOFTWARE 
REQUIREMENT

Disk space: 1GB;
RAM: 1GB;
IBM PC-compatible;
OS: Windows 7.0/8.0/8.1/10
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9. LICENSE

The software can be freely used for scientific and educa-
tional purposes. If used for commercial purposes, it is nec-
essary to notify the exclusive right holder (Kazan Federal
University) and the author (Dmitrii Suchkov). WEEGIT is
developed in MATLAB, therefore a run-time module for
MATLAB R2016a is included in the installation executable
file. Installation file is designed for direct installation on
Windows system without additional preparations.

Link to the free installation file (current version 4.62):
https://gitlab.com/lab-equipment-assemblies1/weegit-
public/-/blob/main/wEEGit_full_installator.exe

Link to the free update patch (current version 4.63):
https://gitlab.com/lab-equipment-assemblies1/weegit-
public/-/blob/main/wEEGit_update_patch.exe
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WEEGIT – ПРИЛОЖЕНИЕ ДЛЯ ВИЗУАЛИЗАЦИИ И ОПИСАНИЯ 
ДАННЫХ ЭЛЕКТРОФИЗИОЛОГИЧЕСКОЙ АКТИВНОСТИ
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Мастер визуализации информации об электроэнцефаллограмме – “WEEGIT” – про-
граммное обеспечение, предназначенное для визуализации и описания длительных реги-
страций сигналов. Длительные регистрации сигналов существуют в разных областях ис-
следований и широко представлены в нейробиологии. В настоящее время регистрация
электрофизиологической активности утвердилась как “золотой стандарт” в нейробиоло-
гических исследованиях. Поэтому мы предложили и апробировали “WEEGIT” как мощ-
ный и удобный инструмент для описания электрофизиологических записей. Мы объеди-
нили в “WEEGIT” наиболее востребованные функции, представленные в других коммер-
ческих и некоммерческих программах. Представленное программное обеспечение может
работать с широко распространенными форматами записей. “WEEGIT” позволяет адап-
тивно визуализировать до 512 каналов записи в различных временных масштабах без поте-
ри эффективности и без потребления дополнительных машинных ресурсов. Визуализация
также включает опциональный встроенный пространственно-временной анализ (плот-
ность источников тока или плотность потенциалов действия), отображаемый в виде фоно-
вого изображения. Встроенный набор дополнительных процедур фильтрации и преобра-
зования сигнала позволяет улучшить визуализацию записи. “WEEGIT” имеет удобный
графический интерфейс пользователя с возможностью одновременного просмотра и опи-
сания записей в одном рабочем пространстве. Описание может осуществляться как про-
стым внесением текстовой информации, так и интерактивным размещением специализи-
рованных меток и объектов. Программа также позволяет сохранять данные в формате c по-
ниженной дискретизацией как для всей записи, так и для определенных пользователем
событий. В заключение следует отметить, что “WEEGIT” предоставляет большой набор
инструментов для удобной работы как для начинающих пользователей, так и для специа-
листов в области электрофизиологических исследований, включая подготовку данных для
последующего специализированного анализа.

Ключевые слова: электрофизиология, программное обеспечение, анализ
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